TDS Build Errors Due to Wrong .NET Version

May 26, 2016 | Kliment Klimentov

There is no worse feeling than a broken build. OK maybe that is an exaggeration but broken builds can be really soul crushing.

When trying to use TDS on a build server deployment, the build might fail with the following error: “warning MSB3644: The reference assemblies for framework ".NETFramework,Version=v2.0" were not found” and “error MSB3645: .NET Framework v3.5 Service Pack 1 was not found. In order to target ".NETFramework,Version=v2.0", .NET Framework v3.5 Service Pack 1 or later must be installed.”

Installing .NET version 3.5 on the build server should solve the problem. TDS actually requires .NET 3.5 present on the build server for it to run properly.

.NET 3.5 comes as a Windows feature, so you can install it from Control panel -> Programs and Features -> Turn Windows features on or off.